Blog > Cannot communicate with device to read config data

Home Forums ViewPort Cannot communicate with device to read config data

This topic contains 1 reply, has 1 voice, and was last updated by  Anonymous .

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #12300

    Anonymous

    Hanno, no matter what I do I cannot load my program into my C3 or PSC Propeller Boards using ViewPort v4.8.2. The program worked fine using Propeller IDE version 1.3.2. For convenience, I attached a screenshot to show that I have loaded the conduit object plus the config and share functions. Any help will be greatly appreciated as I look forward to taking advantage of the features in version 4.8.2.

    VR, Dennis

    #12302

    Anonymous

    Hanno,

    I finally got my program to load. Under the third topic in the Help menu: “Integrating your Program with ViewPort”, there is a discussion called “Automatically Integrating with ViewPort”. It says: “You can see what supporting code ViewPort adds by clicking on “View>View Code with ViewPort support”. When I did that, it not only installed the conduit object, but the proper timing, sharing of the variables defined in the first global section and tracking of the IO pins. With the timing and variables properly defined, ViewPort 4.8.2 was able to communicate with and load my program onto the C3 propeller board. The important lesson is, read and get familiar with the material as suggested or be prepared for a little frustration.

    VR, Dennis

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.